Search Feedback

78
votes

Prompt users to update scripting runtime if package being imported uses a higher one

Asset Store

-

-

Many times when starting a project the default scripting runtime is set to .NET 3.5.

When importing a package from the asset store that uses .NET 4.5 Scripting language features, the editor will show errors.

I'd like to see the editor pop up a dialog stating that the asset package requires the scripting runtime and asks if you'd like to switch to it, then restart the editor.

Comments (2)

  1. 06321d51caa2fe94ca2a5b72de546233?d=mm

    StephenHodgson-Valorem

    Sep 03, 2018 12:08

    2018.3 Makes the default scripting runtime 4.5 by default.

  2. 3edde463506bba95b9d866f6a8dc1782?d=mm

    MSB-Games

    Jul 26, 2018 04:22

    Yes!We need this!

Your opinion counts

Help us make things better. Share your great idea for improving Unity or vote for other people’s.

Log in to post a new idea

Categories

All

(11034)

2D

(291)

Ads

(63)

AI & Navigation

(83)

Analytics

(130)

Animation

(413)

Asset Store

(371)

Asset Store Publisher

(21)

Assets

(557)

Audio

(185)

Cloud Build

(154)

Collaborate

(70)

Docs & Tutorials

(251)

Editor

(2579)

Everyplay

(17)

Game Performance Reporting

(22)

General

(1003)

Graphics

(903)

GUI

(447)

Input

(173)

Licensing

(93)

Networking

(193)

Physics

(392)

Platforms

(448)

Profiling & Optimization

(84)

Runtime

(188)

Scripting

(1154)

Terrain

(178)

WebGL

(145)